Support Center

What iOS version is compatible with the Vetrax® App?

The Vetrax App is compatible with iOS 10.0 and above.

Did you find this article helpful?