Support Center

What Android version is compatible with the Vetrax™ App?

The Vetrax App is compatible with Android 4.4 (KitKat) and above. However, we strongly recommend utilizing 5.0 (Lollipop) and above in order to take advantage of improvements inherent in newer Android versions.

Did you find this article helpful?